Twilioブログ

PHP4系 ヘルパーライブラリサポート終了(2016年11月末)

masamitsu.saito

Twilio PHPヘルパーライブラリをご利用のお客様のほとんどが PHP5.3以降をご利用かと存じますが、実はひそかに4系も考慮したアップデートが行われてきました。→こちら のような説明もドキュメントに載っています。

この度Twilio社が、正式に 2016年11月30日を以って PHPヘルパーライブラリ4.x のサポートを終了する旨のアナウンスを出し、Twilio Docs の PHPヘルパーライブラリのページ、上部にも赤枠で囲んだメッセージを表示しました。非常に分かりにくいですが、「TwilioのPHPライブラリ 4.x系」が11月末で終了、という内容です。まずは「TwilioのPHPライブラリを5.xにアップグレードしてください」ということが1つ。

そして、この5.x系のライブラリでは4系を考慮したバグフィックス等は行われず、すべて5.3以降をご利用の前提でのアップデートになります。本日時点での推奨PHPバージョンは5.6以降です。「もしPHP 4系をご利用の方がいらっしゃれば、これを機会にPHPを5.3以降へマイグレーションをお進めください」ということが1つ。この場合は、PHPヘルパーライブラリも 5.x系へ切り替えてください。

→こちら で 4系から5系へのマイグレーションに関する参考記事を掲載しています。

  • このエントリーをはてなブックマークに追加

Facebook コメント